必火网络安全培训 > 安全漏洞 > 正文

FasterXML jackson-databind远程代码执行漏洞(CVE-2020-9547)

第九期开班时间:2021年3月22日

抢先领取全套VIP视频教程

+10天免费学习名额

  已有8166人参加


视频课程

姓名 选填

电话

  张*燕188****220722分钟前

  王*军186****864498分钟前

  李*如189****445354分钟前

>>  稍后老师联系您发送相关视频课程  <<



报名CTF挑战赛,  预约名师指导

  已有 2366 人参加
姓名 选填

电话

  郭*明170****234291分钟前

  赵*东189****289646分钟前

  蔡*培135****589722分钟前





   

网络安全渗透测试群(必火安全学院):信息安全渗透测试群

护网行动日薪千元(初级中级高级)群:护网行动必火业余班级

FasterXML jackson-databind远程代码执行漏洞(CVE-2020-9547)


发布日期:2020-03-03
更新日期:2020-03-05

受影响系统:FasterXML jackson-databind 2.x  <= 2.9.10.4描述:CVE(CAN) ID: CVE-2020-9547

FasterXML Jackson是一款适用于Java的数据处理工具。jackson-databind是其中的一个具有数据绑定功能的组件。

FasterXML jackson-databind 2.9.10.4 > 2.x版本在ibatis-sqlmap以及anteros-core组件的实现中存在安全漏洞,攻击者利用该漏洞可以绕过黑名单限制,在受害者机器上远程执行代码。开启了autoType功能的用户会受此漏洞影响(autoType功能默认关闭)。

<*来源:vendor
  *>

建议:厂商补丁:

FasterXML
---------
官方暂未发布修复该漏洞的新版本,开启了autoType功能的受影响用户可通过关闭autoType来规避风险,另建议将JDK升级到最新版本。
autoType关闭方法:
方法一: 在项目源码中全文搜索如下代码,找到并将此行代码删除: ParserConfig.getGlobalInstance().setAutoTypeSupport(true);
方法二: 在JVM中启动项目时,不要添加如下参数: -Dfastjson.parser.autoTypeSupport=true:

本文为原创,版权归 必火网络安全培训所有。禁止转载,后果自负。